View on GitHub
Predicate functions/macros should be named accordingly:
* For functions, they should end in a question mark.
defp user?(cookie) do
defp has_attachment?(mail) do
# not okay
defp is_user?(cookie) do
defp is_user(cookie) do
* For guard-safe macros they should have the prefix `is_` and not end in a question mark.
Like all `Readability` issues, this one is not a technical concern.
But you can improve the odds of others reading and liking your code by making
it easier to follow.