Guard::PluginUtil#initialize_plugin

Parsed documentation:
View on GitHub
Initializes a new `Guard::Plugin` with the given `options` hash. This
methods handles plugins that inherit from the deprecated `Guard::Guard`
class as well as plugins that inherit from `Guard::Plugin`.

@see Guard::Plugin
@see https://github.com/guard/guard/wiki/Upgrading-to-Guard-2.0 How to
upgrade for Guard 2.0

@return [Guard::Plugin] the initialized plugin
@return [Guard::Guard] the initialized plugin. This return type is
  deprecated and the plugin's maintainer should update it to be
  compatible with Guard 2.0. For more information on how to upgrade for
  Guard 2.0, please head over to:
  https://github.com/guard/guard/wiki/Upgrading-to-Guard-2.0
Suggestions:
Please help! Open an issue on GitHub if this assessment is incorrect.